Likes_count and other fields empty

#1

Is anyone else having problems with the Shinesty and Kristen datasets? I have no results for many of the columns including comments_count and likes_count.
I used the step by step directions here: https://learn.panoply.io/instagram-data-challenge#requirements

1 Like
#2

Hi Tiffany,
I’m looking into this myself and alerting our support.
I’ll try to get an answer soon.

#3

Hey there @tiffany6872, I just did a fresh import based off the S3 Bucket holding the Shinesty data sets…and these fields have data.

I’ve attached a screenshot below:
34%20AM

#4

Please re-check your procedure against the instructions.

For example, did you click advanced and set the delimiter with the | (pipe) ? It’s the sixth bullet point.

#5

Yes I used the pipe per the instructions. I’ll try with this new import and check back in just a few minutes. Thanks.

#6

It’s possible I am doing something very wrong:

Here is what I am using for the S3 pull:

But there is no results when running looking for likes_count.Some fields show up, but not the ones I need. I tried to post a screenshot of the empty fields but the forum is only allowing me to post one picture.

Is my config correct?

My query is
SELECT * FROM shinesty_ WHERE likes_count IS NOT NULL;

#7

I also tried with Kirsten’s instagram with the same results. I’d like to use Kirsten’s for the challenge if I can get it working.

#8

Ok I see two issues.

One - your destination is set incorrectly. It should be: ShinestyInstagram_{table_name}

So your tables are coming in with the wrong names.

Secondly, your query is incorrect…in your case, there’s no table named shinesty_

When you do your import correctly, the table name with that column will be instagram_media

For more info on table names and columns - see the docs.

1 Like